Tu connais la fonction NB.SI?

Fonction NB.SI Excel
Découvrez tout sur la fonction NB.SI Excel ! Boostez vos compétences avec notre guide complet, des exemples concrets aux astuces avancées.

Nous sommes déjà au jour 5 de notre défi “30 jours, 30 fonctions Excel”, où nous allons explorer la fonction NB.SI d’Excel. Si vous vous êtes déjà demandé “combien de fois ce chiffre apparaît-il?” ou “y a-t-il trop de “oui” dans ces réponses ?”, alors vous allez apprécier la discussion d’aujourd’hui.

 

La fonction NB.SI est l’outil idéal pour répondre à ce type de questions. Elle vous aide à compter efficacement et précisément dans diverses situations. Alors, sans plus attendre, plongeons ensemble dans les subtilités et les possibilités offertes par cette fonctionnalité indispensable. C’est parti !

 

 

Disponible sur Microsoft 365, Excel pour le web et les versions après Excel 2007.
Passez à Microsoft 365 pour avoir en permanence la version la plus à jour d’Excel!

 

 

1. Se familiariser avec la fonction NB.SI d’Excel

 

Comment fonctionne la fonction NB.SI ?

Si vous avez déjà demandé : “Combien de fois cette valeur apparaît-elle dans ma liste ?”, alors NB.SI est la réponse. Il suffit de lui donner deux informations :

  1. Où chercher (la plage)
  2. Quoi chercher (le critère)

Et voilà, NB.SI se charge du reste, comptant chaque fois que le critère apparaît dans la plage ?.

 

Exemple concret avec la fonction NB.SI

Pour illustrer cela, prenons un tableau de ventes. Nous allons compter le nombre de commandes passées par pays ou par client. Prenons ces exemples :

 

 

Cas 1 : Compter les commandes pour le Canada

Si nous voulons le nombre de commandes pour le Canada, nous donnons à NB.SI la plage où chercher (la colonne des pays) et le mot “Canada” comme critère. Le mot doit être mis entre guillemets car c’est en format texte. Et le tour est joué !

 

Fonction NB.SI Excel

 

 

Cas 2 : Compter les commandes hors Canada

Pour compter les commandes à l’extérieur du Canada, nous utilisons un signe double flèche (<>) dans notre critère. Cela signifie que nous voulons toutes les cellules qui ne contiennent pas le mot “Canada”.

 

Fonction NB.SI Excel

 

 

Cas 3 : Adapter le résultat au client sélectionné

Si nous voulons que le résultat change en fonction du client sélectionné, nous référençons simplement cette cellule dans notre critère. Ainsi, à chaque modification de cette cellule, le résultat se met à jour. Pratique, n’est-ce pas ?

Cette fois la colonne de référence est la colonne F qui regroupe tous les clients, et on va rechercher le mot présent dans la cellule I10.

 

Fonction NB.SI Excel

 

 

Cas 4 : Compter les commandes supérieures à 120 000

Enfin, si nous voulons compter toutes les commandes supérieures à 120 000, nous écrivons ce critère entre guillemets. Et voilà le résultat !

Cette fois la colonne de référence est la colonne E qui détaille les montant des commandes.

 

Fonction NB.SI Excel

 

 

 

2. Aller plus loin avec la fonction NB.SI

Après avoir exploré les bases de la fonction NB.SI, nous sommes prêts à découvrir quelques autres astuces étonnantes que cette fonction peut faire.

 

Compter les cellules vides avec NB.SI

Oui, vous avez bien lu. Avec NB.SI, vous pouvez compter le nombre de cellules vides dans une plage donnée. Comment? Il suffit d’utiliser “” (deux guillemets) comme critère. Pratique pour trouver rapidement combien d’informations manquent. Par exemple, pour calculer le nombre de cellule vides dans la plage de cellules A1:B8, il suffit d’entrer cette formule: =NB.SI(A1:B8;””).

 

Et pour compter les cellules non vides, cette fois on va utiliser cette formule:  =NB.SI(plage, “<>”).

 

Utiliser des jokers avec NB.SI

Avez-vous déjà voulu compter les cellules qui correspondent à un certain motif? NB.SI vous a couvert. En utilisant les caractères joker (*) et (?), vous pouvez le faire.

Par exemple:

  • Joker “*” : =NB.SI(A1:B8;”Ca*”) comptera toutes les cellules dont le texte commence par “Ca”.
  • Joker “?” : =NB.SI(A1:B8;”Ca??”) comptera toutes les cellules dont le texte commence par “Ca” et ayant exactement 4 lettres.
    =NB.SI(A1:B8;”????”) comptera toutes les cellules dont le texte contient exactement 4 lettres.

 

Compter des dates spécifiques avec NB.SI

Avec NB.SI, vous pouvez compter des dates qui correspondent à des critères spécifiques. Par exemple, vous pouvez compter combien de ventes ont été réalisées dans les 3 derniers mois avec la fonction AUJOURDHUI. Un outil précieux pour l’analyse des ventes !

La formule serait: =NB.SI(F4:F8;”>”&AUJOURDHUI()-90)

 

N’oubliez pas que toutes les fonctions qui comptent un nombre de cellules non vides commencent par NB. Si vous oubliez le nom d’une fonction, commencez simplement par écrire =NB dans une cellule, et choisissez la fonction qui vous intéresse grâce à la description qui s’affiche à côté.

 

En bref, la fonction NB.SI est incroyablement flexible et utile. Peu importe le critère que vous avez, NB.SI peut probablement le gérer ! Nous espérons que ces astuces supplémentaires vous aideront à tirer encore plus d’avantages de la fonction NB.SI. N’hésitez pas à expérimenter et à trouver de nouvelles façons d’utiliser cette fonction polyvalente.

 

 

Meilleures pratiques et erreurs courantes

La fonction NB.SI est très pratique, mais comme tout outil puissant, elle nécessite un certain savoir-faire pour être utilisée correctement. Voici quelques erreurs courantes à éviter et les meilleures pratiques à suivre :

 

 

Meilleures pratiquesErreurs à éviter
Utiliser les opérateurs de comparaison comme "<" ou ">", entre guillemets. Par exemple : NB.SI(A1:A10,">20")Une erreur commune est d'utiliser des plages de tailles différentes, ce qui peut entraîner des résultats incorrects ou des erreurs
Utiliser NB.SI.ENS pour des critères multiplesVérifiez qu'il n'y a pas d'espace inutile, "Pomme" et " Pomme " sont des critères différents
Vous pouvez utiliser NB.SI pour compter les cellules vides ou non vides en utilisant "" ou "<>"&"" comme critèreOublier de placer le critère textuel entre guillemets peut conduire à des erreurs

 

 

Conclusion

Des bases à des utilisations plus complexes, NB.SI est clairement une fonction de choix pour quiconque souhaite maîtriser Excel. Elle offre des solutions polyvalentes pour compter selon des critères spécifiques, avec une flexibilité à toute épreuve !

 

Pour aller plus loin n’hésitez pas à rejoindre notre Challenge 30 jours 30 fonctions Excel !

 

Chaque jour pendant 30 jours, vous découvrirez une nouvelle fonction Excel. Imaginez, en un mois, vous aurez exploré 30 fonctions différentes, augmentant considérablement votre expertise Excel ! C’est une opportunité à ne pas manquer pour élever vos compétences Excel au niveau supérieur.

Alors, qu’attendez-vous ? Rejoignez le challenge et commencez dès aujourd’hui à découvrir le monde merveilleux des fonctions Excel!

 

 

 

 

Visionner le tutoriel vidéo

Fonction NB.SI Excel

 

 

 

 

FAQ Fonction NB.SI d’Excel

Utilisez =NB.SI(plage, critère) où "plage" est l'endroit où chercher et "critère" est ce que vous recherchez.

Oui, NB.SI fonctionne avec du texte. Vous devez entourer le critère de recherche de guillemets s'il s'agit de texte.

Non, NB.SI ne compte pas directement les cellules avec des erreurs. Cependant, vous pouvez combiner NB.SI avec ISERROR pour y parvenir.

Oui, vous pouvez utiliser des critères de comparaison comme "<", ">", "<>" avec NB.SI.

 

 

 

 

N’hésitez pas à télécharger le fichier complet pour vous entrainer sur Excel: Exemple NB.SI

Vous appréciez nos ressources gratuites ? Pourquoi ne pas nous offrir un café ?

Cela nous aidera à continuer à produire du contenu de qualité pour vous.